THREATINT

We use these services and cookies to improve your user experience. You may opt out if you wish, however, this may limit some features on this site.

Please see our statement on Data Privacy.

Fathom (Privacy friendly web analytics)
Zendesk (Helpdesk and Chat)

Ok

Home | EN
Support
CVE
PUBLISHED

CVE-2020-19909

Assignermitre
Reserved2020-08-13
Published2023-08-22
Updated2024-07-08

Description

Integer overflow vulnerability in tool_operate.c in curl 7.65.2 via a large value as the retry delay. NOTE: many parties report that this has no direct security impact on the curl user; however, it may (in theory) cause a denial of service to associated systems or networks if, for example, --retry-delay is misinterpreted as a value much smaller than what was intended. This is not especially plausible because the overflow only happens if the user was trying to specify that curl should wait weeks (or longer) before trying to recover from a transient error.

References

https://github.com/curl/curl/pull/4166

https://daniel.haxx.se/blog/2023/08/26/cve-2020-19909-is-everything-that-is-wrong-with-cves/

cve.org CVE-2020-19909

nvd.nist.gov CVE-2020-19909

Download JSON

Share this page
https://cve.threatint.com/CVE/CVE-2020-19909
© Copyright 2024 THREATINT. Made in Cyprus with +